Back to overview
Downtime
SSL security affected
Nov 13 at 03:25am EST
Affected services
superfree.host
Control Panel
Free Subdomains
Resolved
Nov 13 at 05:48pm EST
The issue has been resolved.
Affected services
Updated
Nov 13 at 04:44pm EST
A report has been submitted to Google. Services should be back up within 6 hours.
Affected services
Created
Nov 13 at 03:25am EST
Due to an error with Google, many browsers will display warning for the homepage, control panel, and free subdomains. This is Googles fault, and should be fixed soon.
Affected services