Back to overview
Degraded
AWS Outage
Oct 20, 2025 at 8:23am UTC
Resolved
Oct 20, 2025 at 10:01pm UTC
The AWS outage has been resolved.
Affected services
Created
Oct 20, 2025 at 8:23am UTC
Some servers are affected due to the ongoing AWS outage.
Affected services